Trade FOREX with FXCM

  • Award-Winning Platform
  • 24/7 Customer Support
  • Trade Directly on Charts
  • Free $50K Practice Account
Register


Results 1 to 15 of 15
  1. #1
    vgmarinov is offline Member
    Join Date
    Nov 2006
    Posts
    22

    New FXOrder2Go API

    My software was running fine, but after last weekend's update I cannot login. I get the following error: "This is a new version of FXOerde2Go API, please run updater program." But it does not tell me where I find this updater program.

    Also, I understand that FXCore reference library will be phased out, and it should be replaced with Order2GO.CORE, but I could not find the latter in the COM libraries list. Could you clarify this?

  2. #2
    FXCM Help is offline DailyFX Administrator
    Join Date
    Jan 2006
    Posts
    2,190

    Updating Order2Go and Using Order2Go.CORE vs FXCM.CORE

    You can update Order2Go through:
    Start>Program Files>FX Order2Go>Update Order2Go

    As of now, when you instantiate the core, you have to instantiate "Order2Go.CORE" as opposed to the previous "FXCM.CORE".
    If you are unsure about how to instantiate the cores, please review the example provided with the API in the examples directory:
    Start>Program Files>FX Order2Go>Examples

    You can also review the getting started guide at:
    Start>Program Files>FX Order2Go>Order2Go Getting Started Document

  3. #3
    vgmarinov is offline Member
    Join Date
    Nov 2006
    Posts
    22

    Indirect reference to FXCM.CORE in core instantiation

    Thank you for your timely response FXCM Help! I have updated successfully.

    Regarding the phasing out of FXCM.CORE, I still need a bit of help. In my program I never refer to FXCM.CORE directly. And as I prefer the minimal number of corrections, I wonder whether the phasing in of Order2Go.CORE might not happen implicitly in my case.

    In the Program class I have the declaration:
    static FXCore.CoreAutClass core;

    In the Main method I have this instantiation:
    core = new FXCore.CoreAutClass();

    tDesk is handled in a similar way.

    And, of course, I have a reference to FXCore.

  4. #4
    Professor is offline Member
    Join Date
    Dec 2010
    Posts
    7
    Quote Originally Posted by vgmarinov View Post
    My software was running fine, but after last weekend's update I cannot login. I get the following error: "This is a new version of FXOerde2Go API, please run updater program." But it does not tell me where I find this updater program.

    Also, I understand that FXCore reference library will be phased out, and it should be replaced with Order2GO.CORE, but I could not find the latter in the COM libraries list. Could you clarify this?
    I also have a similar problem to this and I wonder whether FXCM can help us update FXOrder2go.

    Thanks.

  5. #5
    TheRookie is offline Member
    Join Date
    Oct 2010
    Posts
    13
    Quote Originally Posted by Professor View Post
    I also have a similar problem to this and I wonder whether FXCM can help us update FXOrder2go.

    Thanks.
    Same problem here...

  6. #6
    joaocosta is offline Member
    Join Date
    Mar 2010
    Posts
    11
    I imagine you just need to download the newer version and install it. (See the link in http://forexforums.dailyfx.com/order...-releases.html )

    However, after installing the new version, I keep getting the message:


    Login error: Cannot connect to www.fxcorporate.com server.
    Trade and update servers are only available during normal trading desk hours.If you have received this error during normal trading desk hours, there may be a problem with your network settings or firewall software which is preventing the connection to the servers. Check it or contact your system administrator.

    What port does the API try to connect on fxcorporate.com ?

  7. #7
    Natalya is offline Member
    Join Date
    Apr 2009
    Posts
    775
    Quote Originally Posted by TheRookie View Post
    Same problem here...
    Please read this article for details on how to update Order2Go: How to Update Order2Go?

  8. #8
    jbush68 is offline Member
    Join Date
    Sep 2010
    Posts
    6
    Are you people crazy!!??? Why does this update have to be so convoluted and difficult? I'm starting to think going with this company was a bad mistake. Terrible user support.

  9. #9
    Natalya is offline Member
    Join Date
    Apr 2009
    Posts
    775
    I do apologize for any inconvenience caused by the update.

    Could you please specify which problems exactly you encountered when updating and I'll do my best to help you.

  10. #10
    Nikolay.Gekht is offline Moderator
    Join Date
    Oct 2008
    Posts
    1,024
    If you use Order2Go in .NET application you must re-create the interoperation assembly. This assembly is NOT a part of the installation package and is created automatically by the Visual Studio when a reference to COM library is added to the project.

    As far as I know, the simplest way to update the interoperation assembly is to remove the reference from the project and then add it back again.

  11. #11
    okh
    okh is offline Member
    Join Date
    Nov 2010
    Posts
    6
    Can you help me please with this error after the update?
    http://i55.tinypic.com/28m4g8.jpg
    Last edited by okh; 07-29-2011 at 04:08 PM.

  12. #12
    rkichenama is offline FXCM Automated Platform Specialist
    Join Date
    Jun 2011
    Posts
    194
    Could you please post the image to TinyPic so we may view it?
    Richard Kichenama
    API Support

  13. #13
    okh
    okh is offline Member
    Join Date
    Nov 2010
    Posts
    6
    I did it, but it doesn't work either! However you can just click the link and you'll view it. Thanks!

  14. #14
    rkichenama is offline FXCM Automated Platform Specialist
    Join Date
    Jun 2011
    Posts
    194
    Instead of the packaged update, please use this link in order to download and update Order2Go.
    Richard Kichenama
    API Support

  15. #15
    okh
    okh is offline Member
    Join Date
    Nov 2010
    Posts
    6
    Thanks, it works perfectly now!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Disclaimer: Trading foreign exchange on margin carries a high level of risk, and may not be suitable for all investors. The high degree of leverage can work against you as well as for you. Before deciding to trade foreign exchange you should carefully consider your investment objectives, level of experience, and risk appetite. The possibility exists that you could sustain a loss of some or all of your initial investment and therefore you should not invest money that you cannot afford to lose. You should be aware of all the risks associated with foreign exchange trading, and seek advice from an independent financial advisor if you have any doubts. Any opinions, news, research, analyses, prices, or other information contained on this website is provided as general market commentary and does not constitute investment advice. Forex Capital Markets LLC. will not accept liability for any loss or damage, including without limitation to, any loss of profit, which may arise directly or indirectly from use of or reliance on such information.